Forum/Support Market
Busy icon
I am unable to withdraw and deposit anything from my vip account at least since tuesday night. Everything involving my trade URL returns "Trade offer url invalid, your trade offer url is unusable, etc."

I generated a new trade URL on my Steam profile, but even after setting up the new URL here the behaviour is still the same "Trade offer url invalid".

I know, in the past this problem usually went away by itself after a while, but this time it seems it doesnt. Can you please verify this and give some feedback?


+1.Please fix it.:((((((((((((((((((

It's actually been weeks for me. Can't trade at all :(

It gets worse: I just noticed my new trade url was not being saved when I click "Save", as it is producing the same error message when I try to save the new one, not saving it, and keeping the old URL. So now Im locked out for good, as the URL the site keeps (the old one) is now effectively invalid at Steam, and I cant save the new one. JOTO, PLEASE CHECK THIS.


Joto got in touch with some feedback. It seems it was again a Steam API days long hiccup. A little while ago I was able to update my new trade URL here, and everything seems to be working fine again, deposits and withdrawals.

It is actually some Steam change that broke our bot. It is now fixed. Thanks for reporting.