Forum/Support Market
Busy icon
Logged in and I see the site forcing me to set up Google Auth again. (I had it removed before due to losing my phone)
I tried to set it up again, but the button (Verify Code) is not doing anything. like no reaction at all.
So I tried checking the network tab in browser to see if the request is being sent, but I see it is not being sent and instead we getting +1 javascript error everytime I click the button.
The Error is this:
It's coming from unidentified "$", which I assume mean that Jquery is not being loaded correctly?
Not sure why is this happening. I also used a VPN and Clear catch on browser, but still the same.

I am using Firefox, I wanted to try using Chrome but kinda lazy to login Steam & there all over again since it ask for Steam Auth too lol
I try again in a day or two to see if this is fixed or not, maybe it's just some CDN failing atm.
But I made this post in case its a real bug, so you can fix it.

umm okay so yeah, it appear the site was not loading correctly as I suspected.

I guess it was not forcing me to set up Google Auth again, rather it was only loading the "Google Authenticator not setup!" panel and the rest of the site simply didn't load.
now 15min later and the site is loading my shop again despite me not setting up the authenticator yet lol

So consider this Solved.
Maybe look into why the site was not loading completely but it was only ~15 minute so most likely some unlucky timing server downtime or something negligible.